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ПЕРЕЛІК СКОРОЧЕНЬ 

 

ACLK – Auxiliary CLocK (допоміжний тактовий сигнал) 

ADC – Analog-to-Digital Converter (аналого-цифровий перетворювач, 

АЦП) 

AM – Active mode (активний режим)  

BOR – Brown Out Reset (скидання при пониженні напруги живлення) 

CCE – Code Composer Essentials 

CPU – Central Processing Unit – центральний процесор 

DAC – Digital-to-Analog Converter (цифро-аналоговий перетворювач, 

ЦАП) 

DCO – Digitally Controlled Oscillator (генератор з цифровим управлін-

ням) 

GIE – General Interrupt Enable (загальний дозвіл переривань) 

IDE – Integrated Development Environment (інтегроване середовище роз-

робки) 

I/O – Input/Output (введення/виведення) 

ISR – Interrupt Service Routine (процедура обробки переривань) 

ISP – In-System Programming (внутрішньосхемне програмування) 

LSB – Least-Significant Bit (молодший значущий біт) 

LSD – Least-Significant Digit (молодший значущий розряд) 

LPM – Low-Power Mode (режим пониженого енергоспоживання)  

MAB – Memory Address Bus (шина адреси) 

MCLK – Master CLocK (основний тактовий сигнал) 

MDB – Memory Data Bus (шина даних) 

MSB – Most-Significant Bit (старший значущий біт) 

MSD – Most-Significant Digit (старший значущий розряд) 

NMI – Non-Maskable Interrupt (немасковане переривання) 

PC – Program Counter (лічильник команд) 

POR – Power-On Reset (скидання за ввімкненням живлення) 

PUC – Power-Up Clear (очищення за ввімкненням живлення) 

ROM – Read Only Memory  (пам’ять тільки для читання) 

RAM – Random Access Memory (пам’ять з довільним доступом) 

SFR – Special Function Register (регістр спеціальних функцій) 

SMCLK – Sub-system Master CLocK (додатковий тактовий сигнал) 

SP – Stack Pointer (покажчик стека) 

SR – Status Register (регістр стану) 

TOS – Top-of-Stack (вершина стека) 

WDT – WatchDog Timer (сторожовий таймер) 

R/W – Read/Write (зчитування/записування) 

R/O – Read only (тільки зчитування) 

ОЗП – оперативно запам’ятовувальний пристрій 

ПЗП – постійно запам’ятовувальний пристрій    
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ВСТУП 

 

 

Компанія Texas Instruments на сьогоднішній день є світовим лідером в 

області цифрових сигнальних процесорів (processors) і технологій обробки 

аналогових сигналів (signals). 

В 1999 році компанія Texas Instruments почала виробництво сімейства 

флеш-RISC 16-бітних програмно/конструктивно сумісних мікроконтроле-

рів (microcontrollers) MSP430, що характеризуються наднизьким енерго-

споживанням (ultra-low power). Мікроконтролери MSP430 – це процесори 

для обробки змішаних (аналогових та цифрових) сигналів (Mixed Signal 

Processor – MSP). 

Завдяки своїм унікальним характеристикам мікроконтролери серії 

MSP430 завоювали широку популярність у розробників електронної техні-

ки. Жоден з визнаних світових лідерів у виробництві мікроконтролерів не 

може запропонувати ринку виріб, здатний конкурувати з MSP430 за спів-

відношенням ціна/якість, рівнем управління енергоспоживанням, набором 

розміщених на кристалі вузлів.  

Сьогодні серія мікроконтролерів MSP430 включає більше 100 різних 

модифікацій, які мають флеш-пам’ять від 1 до 128 кілобайтів і кількість 

виводів від 14 до 100, що дозволяє підібрати ідеальне рішення для різних 

додатків (applications). 

За останні роки видано лише невелику кількість книг російською та 

українською мовами, які присвячені дослідженню мікроконтролерів  

MSP430. Ці літературні джерела значною мірою присвячені теоретичним 

аспектам дослідження мікроконтролерів  MSP430. Практичне використан-

ня мікроконтролерів у цих посібниках обмежується елементами програму-

вання мовою асемблер (assembler). При цьому програмуванню мікроконт-

ролерів MSP430 мовами С/С++ не приділяється уваги.  

Даний посібник є продовженням серії посібників, що присвячена ви-

вченню мікроконтролерів MSP430. Першим у серії є посібник «MSP-430. 

Базова модель. Архітектура. Адресація. Система команд».  

У даному посібнику пропонується теоретичне та практичне дослідження 

сімейства мікроконтролерів з наднизьким енергоспоживанням MSP430x2xx 

на базі інструмента розробника (development tool) eZ430-F2013. У практич-

них завданнях, поданих у посібнику, здійснюється програмування пристрою 

(device) eZ430-F2013 мовами С/С++. 

Інструмент розробника eZ430-F2013 призначений для розробки і нала-

годження додатків на базі мікроконтролера фірми Texas Instruments 

MSP430F2013. Він включає в себе програмні (software) та апаратні засоби 

(hardware) в зручному форм-факторі USB-stick. Для розробки додатків і за-

безпечення повної емуляції до інструмента розробника входять інтегровані 

середовища розробки (integrated development environment) IAR Embedded 

Workbench та Code Composer Essential. Крім того, конструктивом інструме-
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нта розробника передбачена заміна знімної плати (detachable target board) 

зовнішнім пристроєм за допомогою спеціально відведених виводів (pins). 

Оскільки інструмент розробника призначений для використання з мікрокон-

тролерами з наднизьким споживанням, живлення пристрою забезпечується 

USB-інтерфейсом (interface) комп’ютера (computer), і зовнішні джерела при 

цьому не потрібні.  

В першому розділі наведено короткий опис IDE IAR Embedded 

Workbench, покрокову інструкцію створення, компіляції, налагоджування 

(debugging) та запуску проекту (project) на виконання, а також розглянуто 

послідовність виконання програми у інтегрованому середовищі розробки. 

В другому розділі наведено короткий опис IDE Code Composer Essentials 

та покрокову інструкцію створення, компіляції, налагоджування та запуску 

проекту на виконання. 

Третій розділ присвячений інструменту розробника eZ430-F2013.   

У четвертому розглядаються система переривань (interrupt system) та 

режими роботи (operation modes) мікроконтролера MSP430F2013. 

У п’ятому розділі розглядаються порти введення/виведення (input/output 

ports) мікроконтролера MSP430F2013.   

У шостому розділі досліджується модуль синхронізації (synchronization 

module) Basic Clock мікроконтролера MSP430F2013. 

Сьомий розділ присвячений ознайомленню зі сторожовим таймером 

(watchdog timer) мікроконтролера MSP430F2013. 

У восьмому розділі досліджується робота Timer_A мікроконтролера 

MSP430F2013. 

Девятий розділ присвячений дослідженню роботи флеш-пам’яті (flash 

memory) мікроконтролера MSP430F2013. 

У десятому розділі розглядається модуль цифро-аналогового перетво-

рення (digital-to-analog conversation) SD16_A мікроконтролера 

MSP430F2013. 

Практичні завдання, подані у посібнику, можуть використовуватися у 

дисциплінах: «Мікропроцесорні системи», «Проектування та програмуван-

ня МПС», «Основи збору, передавання та обробки інформації», «Цифрові 

системи», «Функціональні перетворювачі СУА» а також використовуватися 

студентами напрямку «Системна інженерія», студентами суміжних напря-

мів. 

Розділ 1-2 посібника підготовлено В. В. Гармашем та Р. В. Маслієм, ро-

зділи 3-4 – Р. Н. Квєтним та О. Р. Бойко, розділ 5 – Р. В. Маслієм, розділ 6 –    

Р. Н. Квєтним та В. В. Гармашем, розділ 7 – Р. В. Маслієм, розділ 8 –             

В. В. Гармашем та О. Р. Бойко, розділ 9 – Маслієм Р. В. та Гармашем В. В., 

розділ 10 – Р. Н. Квєтним та Р. В. Маслієм. Загальну редакцію посібника 

здійснено Р. Н. Квєтним. 
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1 ІНТЕГРОВАНЕ СЕРЕДОВИЩЕ РОЗРОБКИ IAR EMBEDDED 

WORKBENCH 

 

1.1 Загальна характеристика IDE IAR Embedded Workbench 

 

IAR Embedded Workbench для MSP430 – це потужне інтегроване сере-

довище розробки і налагодження програм для мікроконтролерів MSP430 за 

допомогою мов C, C++ та асемблера. Середовище забезпечує розширену пі-

дтримку пристроїв MSP430 і створює дуже компактний і ефективний код 

(program code).  

В комплект IAR Embedded Workbench входять: 

 компілятор (compilator) мови С/C++; 

 асемблер; 

 компонувальник (linker); 

 налагоджувач (debugger); 

 редактор. 

IAR Embedded Workbench забезпечує можливість взаємодії з зовнішніми 

програмами (program).  

Особливості компілятора мови C/C++: 

 один з кращих компіляторів за ефективністю коду; 

 повна сумісність з ANSI C; 

 кілька моделей для ефективного розподілу пам’яті; 

 алгоритми оптимізації спеціально для мікроконтролерів MSP430; 

 розширення мови для вбудованих систем (embedded systems). 

Особливості асемблера: 

 інтегрований макроасемблер для додатків реального часу (real time); 

 включає препроцесор для компілятора C. 

Особливості компонувальника: 

 підтримує повне компонування, розміщення і створення формату; 

 підтримує більше 30 стандартних вихідних форматів для викорис-

тання спільно з внутрішньосхемними емуляторами (emulator); 

 завантаження модулів тільки за необхідності. 

Особливості налагоджувача: 

 налагодження кодів C, C++ та асемблера; 

 різні точки зупину (breakpoint); 

 мова опису периферії та операцій введення/виведення; 

 перегляд областей CODE, DATA, EEPROM та регістрів (registers) 

введення/виведення; 

 обробка переривань з прогнозом; 

 контроль будь-яких змінних і стека (stack); 

 комплексні типи даних. 

Особливості редактора вихідного тексту: 
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 зручний інтерфейс користувача; 

 автоматичне виділення помилок; 

 зручна панель інструментів; 

 виділення директив C/C++; 

 розвинені засоби пошуку.  

Вбудований редактор спеціально налаштований на синтаксис мови С, а 

додаткові утиліти і вбудована система допомоги додатково полегшують на-

писання програм. 

 

1.2 Створення проекту в IDE IAR Embedded Workbench 

 

Нижче приводиться опис покрокової процедури (procedure) створення 

проекту в інтегрованому середовищі IAR Embedded Workbench. 

1. Запустити середовище IAR Embedded Workbench. Створити новий 

проект: Project → Create New Project. У меню, що відкрилося,  необхідно 

вибрати Tool chain: MSP430 (рис. 1.1). Натиснути «OK».  

 

 

Рисунок 1.1 – Створення нового проекту 

 

2. Ввести назву проекту, наприклад, «LED Blink» і вказати теку, в якій 

зберігатиметься проект, наприклад, «My Projects\LED Blink» (рис. 1.2). Далі 

натиснути «Сохранить». 
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Рисунок 1.2 – Збереження проекту 

 

3. У вікні середовища розробки, зліва, повинно з’явитися вікно 

Workspace, воно відображає файли проекту. Якщо вікна немає, необхідно 

вибрати View → Workspace. Серед файлів можна побачити файл LED Blink 

(рис._1.3). Клацнути по ньому правою кнопкою мишки і вибрати Options. 

 

 

Рисунок 1.3 – Вікно Workspace 

 

4. У категорії General Options в графі Device вибрати мікроконтролер, з 

яким необхідно працювати: MSP430F2013 (рис. 1.4). 
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Рисунок 1.4 – Вибір мікроконтролера  

 

5. У категорії Debugger, закладці Setup, графі Driver вибрати FET 

Debugger (рис. 1.5). Натиснути «OK». 

 

 

Рисунок 1.5 – Налаштування категорії Debugger 

 

6. Тепер необхідно створити файл, в якому буде розміщена програма: 

File → New → File. Відразу необхідно зберегти його: File → Save As. Назва-

ти його, наприклад «LED Blink.c». 
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7. Скопіювати у файл «LED Blink.c» код програми (рис._1.6): 

 
#include  <msp430x20x3.h> 

void main(void) 

{ 

  WDTCTL = WDTPW + WDTHOLD;/*Зупинка сторожового                            

                                таймера */ 

  P1DIR |= 0x01; /* Налаштування порту P1.0 на  

                     виведення */ 

  for (;;) 

  { 

    volatile unsigned int i; 

    P1OUT ^= 0x01;/* Перемикання порту P1.0 з                            

                    використанням виключного АБО */ 

    i = 50000;    // Затримка  

    do  

    { 

      (i--); 

    } 

    while (i != 0); 

  } 

} 

 

 

Рисунок 1.6 – Програма «LED Blink.c» 

 



 

 13 

8. Зберегти файл «LED Blink.c» після змін. Підключити його до проекту: 

правою кнопкою мишки клацнути у вікні Workspace по назві проекту, виб-

рати Add → Add Files, потім файл «LED Blink.c» (рис. 1.7). 

 

 

Рисунок 1.7 – Підключення файлу до проекту 

 

9. Компіляція проекту. Вибрати пункт головного меню: Project → 

Rebuild All (рис. 1.8). Відкриється вікно з пропозицією зберегти робочу об-

ласть: Save Workspace As. Зберегти робочу область в тій же теці My 

Projects\LED Blink. Натиснути «Save». 

 

 

Рисунок 1.8 – Компіляція проекту 
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10. Налагодження проекту та запуск на виконання. Для налагодження 

пристрій eZ430-F2013 повинен бути підключений до USB порту. Натиснути 

Project → Debug (рис. 1.9). Натиснути F5 і спостерігати як блимає світлоді-

од. Для зупинення блимання світлодіода потрібно натиснути Debug → 

Break, для виходу з режиму налагодження: Debug → Stop Debugging. 

 

 

Рисунок 1.9 – Налагодження проекту 
 

1.3 Виконання програми на С/С++ у інтегрованому середовищі 

розробки 

 

На рис. 1.10 наведено послідовність виконання програми на С/С++ у ін-

тегрованому середовищі розробки. 

Основні елементи послідовності виконання програми на С/С++ у IDE:  

 файли С/С++; 

 компілятор С/С++; 

 код асемблера; 

 асемблер; 

 об’єктні файли (object files); 

 компонувальник; 

 виконуваний об’єктний файл; 

 MSP430. 

Інші елементи, наведені на рис. 1.10, є опціональними. 
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Рисунок 1.10 – Послідовність виконання програми на С/С++ у IDE 

 

Компілятор перетворює код С/С++ на код асемблера MSP430.  

Тобто якщо записати в програмі код: 

 
int а,b,c; 

а = 3; 

b = 5; 

с = a+b; 

 

Компілятор перетворить цей код таким чином: 

 
mov.w   #0x3,R15 

mov.w   #0x5, R14 

add.w   R14,R15 
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Завдяки компілятору програміст може використовувати мову С/С++, що 

значно спрощує процес розробки програмного забезпечення. Саме у обсязі 

компільованого коду виробники IDE для MSP430 вносять обмеження для 

того, щоб надати безкоштовну тестову версію. 

Результат роботи компілятора можна побачити у вікні Disassembly, коли 

запускаємо режим налагодження проекту (Project → Debug) в середовищі 

розробки IAR Embedded Workbench IDE. 

Асемблер – це перекладач з мови асемблера на мову машинних кодів, 

тобто в об’єктний код. Таким чином, отриманий код асемблера: 

 
mov.w   #0x3,R15 

mov.w   #0x5, R14 

add.w    R14,R15 

 

на мові машинних кодів буде мати такий вигляд: 

 
00F80E    403F 0003 

00F812    403E 0005 

00F816    5E0F 

 

Компонувальник об’єднує всі об’єктні файли проекту в один виконува-

ний об’єктний модуль.   

Архіватор (arhiver) – дозволяє створювати бібліотеки функцій, які часто 

використовуються, а також модифікувати вже існуючі бібліотеки. На сайті 

Texas Instruments www.ti.com можна безкоштовно завантажити бібліотеки 

оптимізованих функцій для роботи з деякими периферійними пристроями 

(peripheral devices). 

 

Контрольні запитання 

1. Що входить в комплект IAR Embedded Workbench? 

2. Які особливості компілятора мови C/C+? 

3. Які особливості асемблера? 

4. Які особливості компонувальника? 

5. Які особливості налагоджувача? 

6. Які особливості редактора вихідного тексту? 

7. Як відбувається створення проекту в IDE IAR Embedded Workbench? 

8. Яким чином здійснюється компіляція проекту? 

9. Яким чином здійснюється налагодження проекту та запуск на вико-

нання? 

10. Які основні елементи послідовності виконання програми на С/С++ у 

IDE? 

11. Яке призначення асемблера? 

12. Яке призначення компонувальника? 

13. Яке призначення архіватора? 
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СЛОВНИК НАЙБІЛЬШ ВЖИВАНИХ ТЕРМІНІВ 

 

 

Адреса – address 

Аналоговий вхід – analog input 

Апаратне забезпечення – hardware   

Архіватор – arhiver 

Асемблер – assembler 

Байт –  byte 

Біт – bit 

Вбудувана система – embedded system 

Введення/виведення – input/output  

Вектор переривання – interrupt vector 

Вивід – pin  

Вихід – output  

Вхід – input  

Генератор – generator  

Подільник частоти – frequency divider  

Додаток – application 

Емулятор – emulator  

Знімна плата – detachable target board  

Налагодження – debugging 

Налагоджувальний інтерфейс – debugging interface 

Налагоджувач – debugger  

Інструмент розробника – development tool 

Інтегроване середовище розробки – integrated development environment 

Інтервальний таймер – interval timer 

Інтерфейс – interface  

Інформаційна пам’ять – information memory 

Кварцовий генератор – crystal oscillator 

Код програми – source code 

Команда – command 

Комп’ютер – computer  

Компілятор – compiler    

Компіляція – compilation  

Компонувальник – linker  

Конденсатор – capacitor  

Лічильник – counter 

Мікроконтролер – microcontroller  

Модуль – module  

Модуль синхронізації – synchronization module  

Наднизьке споживання – ultra-low power 

Напруга живлення – supply voltage 

Немасковане переривання – non maskable interrupt 
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Об’єктні файли – object files 

Обробка даних – data processing 

Опорна напруга – reference voltage 

Переривання – interrupt  

Периферійний пристрій – peripheral device 

Порт – port  

Прапорець – flag  

Пристрій – device 

Програма – program 

Програмні засоби – software  

Проект – project  

Процедура – procedure  

Процесор – processor 

Реальний час – real time 

Регістр – register  

Режим захоплення – capture mode 

Режим порівняння – compare mode 

Режими роботи – operation modes  

Резистор змінного опору – pull-up/pull-down resistor 

Резонатор – resonator  

Світлодіод – LED 

Сегмент – segment  

Сигнал – signal 

Синхронізація – synchronization  

Система переривань – interrupt system 

Стек – stack  

Сторожовий таймер - watchdog timer  

Тактовий генератор – clock generator  

Тактовий сигнал – clock signal  

Точка зупину – breakpoint 

Транзистор – transistor 

Флеш-пам’ять – flash memory 

Фронт сигналу – signal front 

Цифро-аналогове перетворення – digital-to-analog conversion  

Цифровий вивід – digital pin    

Цифровий фільтр – digital filter 

Частота сигналу – signal frequency 

Швидкість – speed  
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